Issues with Sofar Spotter and Bristlemouth connection

Hello Bristlemouth team,

We are currently working with our Sofar Spotter, and we have come across an issue. We are incorporating the Bristlemouth into our project and we are trying to attempt a connection to the Buoy onto our windows computer. We are following the Devkit instructions in the tutorial provided on their website. We are not able to complete the part of the tutorial in which we have to connect the spotter to our computer to receive information. What are some next steps we could take to debug this issue?

Thank You!


Thanks for reaching out. Can you please provide more information about the issues you are experiencing?

Many Bristlemouth users are having success using alternative serial terminal programs. On Windows, some options include CoolTerm and PuTTY. These are much more user-friendly than Python’s miniterm. They offer helpful features like:

  • separate input fields
  • pausing the scrolling of the terminal window
  • input history
  • scrollback

…and many more.


Thank you for your reply. We tried those serial programs such as CoolTerm, Putty, and the Python Miniterm but are still getting the same reply. The TX of the buoy is working as we are receiving information such as voltage and current, but the RX is not. No matter which terminal program we try, we are not even able to type into the terminal to send commands. The Bristlemouth connection works, both the RX and the TX, but the Spotter connection is not working on the RX side.

Thank you,

Hi @samkitbothra –

This could be an issue with the type of USB-C cable you are using. If it is a high-spec cable supporting the full “Thunderbolt”-style spec (for lack of better terminology), it may be exposing an issue with the Spotter’s USB-C implementation.

  1. Can you try connecting the cable “upside-down” or reversing it, compared to how you have been using it?
  2. Do you perhaps have a lower-grade USB-C cable you can use? We would be looking for a cable that at least supports data transfer. A cable that is designed to only carry power will not suffice.

Please let us know how you fare.


We tried the cable that came with the Spotter and it did not work. We tried reversing as well but we still have no luck. For the lower-grade USB-C cables, we are looking online to find some to order. Do you know any specifications such as which generation such as USB 2.0 or 3.1 Gen 1? If so, do you have any brands in mind from which we can order the cable from?

Thank you

Thanks – maybe the cable is not the issue. Please advise whether you have tried any of the following:

  1. changing linefeed / carriage return settings
  2. changing the baud rate between 9600 and 115200
  3. using a different computer

If none of these make a difference, we may need to discuss whether there is a hardware problem with the Spotter itself.

Could you perhaps provide a screenshot or video of the specific issue with being able to receive data over USB Serial but not send?


Hi @samkitbothra,

Can you please tell us if re-flashing with the firmware that shipped with your Spotter has fixed this issue?


Hi @timjoh
Just a quick update from our work with @samkitbothra. We were finally able to resolve all our issues by using WSL in Windows. It seems that all the instructions in the Bristlemouth documentation work for Linux and Mac OS computers.

1 Like

Great to hear. Yes indeed, the guides are intended primarily for macOS and secondarily for Linux. Glad WSL worked out for you.