Powering the dev kit from the spotter

Hey yall,
My team has been working on integrating a raspberry pi 4 and camera payload to the bristlemouth dev kit and wanted to take our buoy outside to test our the cellular connection. However, we discovered that without the wall-wart adaptor, the dev kit turns off. We couldnt figure out why the spotter is not able to provide any power to the dev kit through the smart mooring and were hoping to get some direction with that.
With the dev kit powered on with the wall-wart adaptor the spotter printf command works fine and when we unscrew the bristlemouth cables from the smart mooring, the Spotter’s CLI reads neighbor lost so we’re thinking the data connection is there meaning our physical connections are OK but are just unsure how to deliver power to the system.

@vsowa12 Do you think this might be a firmware bridge setting?


It is likely that the Spotter is using its power controller to turn the Bristlemouth bus on/off. This is a power saving feature for sensor applications that allows for set sampling times, say a pattern of 5 minutes on every 30 minutes. Turning the power controller off will leave the bus enabled all the time. You can check if it is enabled and turn it off in the Spotter CLI.

To check if it is on you connect to the Spotter USB and type:

bridge cfg get 0 s bridgePowerControllerEnabled

And you should receive a response similar to:

Succesfull status request send
2024-03-05T19:11:47.140Z [BRIDGE_CFG] [INFO] Response msg -- Node Id:0,Partition:system, Commit Status:0

Here we can see that it currently off because the value that is saved is 0: Commit Status:0. If it were 1, the power controller would be enabled.

To turn the power controller off you can use:

bridge cfg set 0 s u bridgePowerControllerEnabled 0
bridge cfg commit 0 s

If you want to see all of the configs, type:

bridge cfg status 0 s

Right now the bridge cfg commands only allow for you to set/get the configs of the Spotters bridge. However, in an upcoming release you will be able to use these commands with any node that is connected to the Spotter.

Hope this helps!

1 Like

So we went to check out the power controller situation but it turns out that it was not on to begin with (tried telling it to turn off anyway hoping it might help) but there is still no power reaching the dev kit :pensive:
any other tips on how to move forward would be appreciated :slight_smile:

Hey there @Kaitlynyau , can you attempt the following set up so we can make sure we’re all on the same page with the issue:

  • With the wall wart plugged in use a multimeter to carefully test the voltage between the black and white contacts on the other end of the cable. We generally don’t recommend leaving this plugged in and these conductors exposed but just for this test. Let us know what the voltage is.
  • Unplug the wall wart from the wall and connect the black and white jumpers to only one port of the endcap (both black and white sockets on the same passthrough cylinder).
  • Plug the wall wart back in. Do you observe any LEDs on the orange development board?
  • Next using a data rated USB-C cable, connect the development board to your computer and try to connect using the serial terminal (python3 -m serial for example…but there are other methods).
  • Let us know what you observe here.

Thank you.

  • This was actually one of the first things we tried (probing every possible node and then some) and discovered that wall wart → bristlemouth cables read 5V with one probe on each cable. We also probed the end of the Spotter’s smart mooring nodes and this read a fat 0V so we strongly suspect that something is going wrong with the power much before the physical connections established.
  • With solely the wall wart going in to the dev kit and no spotter connection, the dev kit has a green LED ON. Once the wall wart is unplugged the dev kit strictly goes back to being off. So the data we were sending between spotter and dev kit was all only with the wall wart powering the dev kit board.
  • Im not sure if this USB-C cable setup involves wall wart power or not but in any case without the LED on the dev kit being on, no serial connection was able to be established (so only being able to access the CLI with wall wart power). Throughout the testing I kept the USB-C cable connected from my laptop to the dev kit because the accessory notification pops up on my screen when the dev kit has a valid connection. We even tried keeping Raspberry Pi’s plugged in so we would see those LED’s turn on in the case of power delivery but the dev kit’s LED was just not on but this did not produce any results.

Hopefully this gives some insight as to where we are stuck right now!

Hmmm… is just just the wall wart in isolation? You should be getting 24V from that. (see photos).

I just want to make sure this is working. If you are getting 24V purely on the wall wart we can move onto the next step.

For this set up:
a) The wall wart is plugged into the wall and the BM connectors from the wall wart are connected to the Dev Board via the port (shown below).

b) A data-cabable USB-C cable is connecting the Dev Board to the computer.

c) No other things are connected anywhere else (except the wall wart and USB-c cable)

If you’re able to use the serial terminal to connect and see data and send data over the CLI I think we are safe to say the Development Board is working. (I’m happy you’re seeing the green LED, that’s good news. Let’s just confirm the firmware is okay too).

Once we confirm that the development board is behaving as normal we can take a look to make sure the Spotter is behaving as intended. I want to check one thing on that first…

  1. Charge up the Spotter fully ( a few hours ) using the provided wall charger. Often when the battery is low the Spotter will turn off the “bridge” that controls the power to the Bristlemouth system below.

With the Spotter fully charged, you can probably re-try your operation. If everything is not working correcetly then I would re-attempt the steps that @vsowa12 outlined above and let us know the result.


1 Like

the pi4 needs more current than the spotter/ devkit can supply. For example the +5V is limited to 600mA, so the Pi 4 has no current enough to start and the protection circuit will shut down the power.

Hello again!

I totally misunderstood the wall wart prompt, the 5v was in face probed when it was plugged into the outlet. In isolation, we are reading 24v now (phew!)

Now with the wall wart providing power through the bm connectors, we can connect with USB-C to send data over the CLI to the Spotters CLI. This was our earlier confirmation of a functional data connection.

The Spotter was left charging overnight prior to our setups, so this should not have been the issue, we were pretty certain it was fully charged. Just to make sure nothing was entered in wrong or anything, the steps given above were repeated to make sure the bridge power enabler was in fact off. However, the dev kit is still receiving no power without the wall wart.

As for the tip from @asantos, we were very aware that this might be an issue and were slightly hoping that perhaps an underpowered Pi 4 might slide through. Anywho, for the purposes of this forum post id like to clarify that there is absolutely nothing plugged into the dev kit and yet, the power is still not even making it to the dev kit :frowning:

Since then, we’ve tried eliminating a node on the smart mooring and probing more nodes with our DMM, but there are no readings coming up. To us, it seems like the last explanation is that there is no power leaving the spotter to begin with and it might just need to be enabled somehow? It feels like we’ve checked everything else that could explain this dilemma and have hit a wall with things to try out.

Well, we look forward to hearing from you guys and are trying to move forward in other areas of our project in the meantime,

-The MSI capstone team

I had a similar issue when I start with the devkit then I look at the RS232 tutorial and I just found that the voltages like 5V need to be enabled via software. I’m not a software expert and I can’t help in this subject but probably others can.

Thanks for your patience in a reply, @Kaitlynyau.

Can you please do the following. Connect the Spotter to the computer using the USB-C cable. With the Spotter in the off position, open the CLI. Turn the Spotter to the “on” position and copy what you see into a text file or paste it here. We’d want to see the first 60 seconds of data that shows in the CLI.


Its great to hear from you again! Here is what im seeing when im connecting to the Spotters CLI. Im not sure if this is everything you’re looking for but unfortunately this morning when we went to work with the dev kit it was not exactly performing as expected/was heating up quite hot when connected to both the wall wart and spotter (and spotter ON). So currently there is no dev kit data showing up in the spotters CLI but hopefully something here might help indicate what is going on with the spotter!

Blockquote 2024-03-18T20:24:44.746Z [BRIDGE_SYS] [INFO] Sample enabled 0
Sample Duration: 60 s
Sample Interval: 360 s
Subsample enabled: 0
Subsample Duration: 30 s
Subsample Interval: 60 s
Alignment Interval: 300 s
2024-03-18T20:24:44.753Z [BRIDGE_SYS] [INFO] Bridge State Init Complete
2024-03-18T20:24:57.644Z [ERR] [INFO] GpsErrorState changed from NO_SIGNAL to OK
2024-03-18T20:24:57.644Z [SYS] [WARNING] Updating RTC from GPS time.
2024-03-18T20:24:57.644Z [SYS] [WARNING] RTC not within threshold (4 seconds off)
2024-03-18T20:24:57.648Z [SYS] [INFO] DeltaValues: GPS - RTC (s) = 1710793501 - 1710793497 in DeltaTime (s) = 1710793501 - 171079350
2024-03-18T20:24:57.648Z [SYS] [INFO] Old Values CALM: 188, CALP: 0. New Values CALM: 187, CALP: 0
2024-03-18T20:24:57.648Z [SYS] [INFO] RTC Frequency Updated
2024-03-18T20:25:01.000Z [SYS] [INFO] RTC updated
2024-03-18T20:25:01.027Z [MS] [INFO] Added message(id: 0 len: 145) to queue MS_Q_LEGACY: (1)!
Message: DC 65 F8 A3 1D E2 74 AC 01 E9 A1 13 09 85 DF 1B 0E 03 B6 67 5D 40 19 A5 C9 12 C3 20 80 3B 00 17 A1 40 3C 10 0B B9 94 60 F1 B5 89 62 71 00 00 0C 37 2D 0D 20 BF 4E 7B C6 B3 03 A0 74 89 8C 64 C7 96 64 B0 01 E1 F4 24 50 78 01 F4 01 DB E8 00 00 00 00 00 00 00 02 FF 85 10 A7 58 36 CA 19 80 6C 01 90 C7 0C 45 40 00 C1 81 D8 1F 40 1D 80 E8 1E 03 84 00 12 C2 45 40 40 00 38 48 22 13 94 E1 08 48 9C E5 29 D5 90 9C 63 18 4E 10 84 25 28 CA 8B 3E
2024-03-18T20:25:01.027Z [MFLT] [INFO] Sending memfault message!
Current bit offset: 134
Rounded bit offset: 136
New bit offset: 736
2024-03-18T20:25:01.031Z [MS] [INFO] Added message(id: 1 len: 92) to queue MS_Q_LEGACY: (2)!
Message: E4 65 F8 A3 1D E2 74 AC 01 E9 A1 13 09 85 DF 1B 0C 08 02 A8 02 02 03 01 0A 6E 73 70 6F 74 74 65 72 5F 62 6D 2D 64 62 67 09 66 76 32 2E 39 2E 30 06 6E 73 75 6E 66 6C 6F 77 65 72 5F 76 33 2E 33 0B 46 5F 75 A8 A3 79 02 01 1A 65 F8 A2 8F 04 A3 01 0A 04 1A 04 00 06 03 05 00 5A 06
2024-03-18T20:25:01.031Z [MFLT] [INFO] Message 1 added to queue.
2024-03-18T20:25:01.031Z [MS] [INFO] Added message(id: 2 len: 36) to queue MS_Q_LEGACY: (3)!
Message: DD 65 F8 A3 1D E2 74 AC 01 E9 A1 13 09 85 DF 1B 0E 03 B6 67 5D 32 FC 51 8E 80 01 0E EA 40 00 01 00 04 04 51
2024-03-18T20:25:01.035Z [ERR [INFO] OrchErrorState changed from OK to SCHEDULE_SAMPLE_ALIGNMENT
2024-03-18T20:25:01.039Z [ERR] [INFO] Cellular SignalErrorState changed from N/A to CONNECTING
2024-03-18T20:25:01.039Z [MS] [DEBUG] Sending legacy messages to Notecard.
2024-03-18T20:25:01.082Z [MS] [DEBUG] Notecard is 2.000000 pct full.
2024-03-18T20:25:01.082Z [MS] [INFO] Queuing message 0 200097A0
2024-03-18T20:25:01.429Z [MS] [INFO] Queuing message 1 200097F0
2024-03-18T20:25:01.480Z [MS] [INFO] Queuing message 2 20009818
2024-03-18T20:25:01.523Z [MS] [INFO] Setting GPS coordinates lat:34.414692, lon: -119.848076
2024-03-18T20:25:04.398Z [MS] [DEBUG] Attempting to Sync.
2024-03-18T20:25:06.281Z [GPS] [INFO] Max CNO changed from -1 to 35
2024-03-18T20:25:06.980Z [MS] [DEBUG] Waiting for TX
2024-03-18T20:25:32.472Z [ORC] [INFO] Message 0 transmitted successfully!
2024-03-18T20:25:32.488Z [MS] [DEBUG] Notecard is 2.000000 pct full.
2024-03-18T20:25:32.492Z [MS] [INFO] All messages sent successfully!
2024-03-18T20:25:32.492Z [MS] [DEBUG] Checking for Rx Messages
2024-03-18T20:25:35.070Z [ERR] [INFO] Cellular SignalErrorState changed from CONNECTING to OK
2024-03-18T20:25:35.085Z [ERR] [INFO] Cellular SignalErrorState changed from OK to CONNECTING
2024-03-18T20:25:35.085Z [MS] [DEBUG] Sending legacy messages to Notecard.
2024-03-18T20:25:35.105Z [MS] [DEBUG] Notecard is 2.000000 pct full.
2024-03-18T20:25:35.105Z [MS] [INFO] Setting GPS coordinates lat:34.414650, lon: -119.848053
2024-03-18T20:25:35.812Z [ERR] [INFO] GpsErrorState changed from OK to NO_SIGNAL
2024-03-18T20:25:37.398Z [ERR] [INFO] GpsErrorState changed from NO_SIGNAL to OK
Interpolated sample at: 1710793536.20
Interpolated sample at: 1710793536.60
Interpolated sample at: 1710793537.00
Interpolated sample at: 1710793537.40
Interpolated sample at: 1710793537.80
2024-03-18T20:25:37.792Z [MS] [DEBUG] Attempting to Sync.
2024-03-18T20:25:37.808Z [MS] [DEBUG] Waiting for TX
2024-03-18T20:25:42.851Z [MS] [DEBUG] Notecard is 2.000000 pct full.
2024-03-18T20:25:42.851Z [MS] [INFO] All messages sent successfully!
2024-03-18T20:25:42.851Z [MS] [DEBUG] Checking for Rx Messages
2024-03-18T20:25:43.453Z [ERR] [INFO] Cellular SignalErrorState changed from CONNECTING to OK
2024-03-18T20:25:46.292Z [GPS] [INFO] Max CNO changed from 35 to 40
2024-03-18T20:25:47.011Z [ERR] [INFO] GpsErrorState changed from OK to NO_SIGNAL
2024-03-18T20:25:52.199Z [ERR] [INFO] GpsErrorState changed from NO_SIGNAL to OK
Interpolated sample at: 1710793555.40
Interpolated sample at: 1710793555.80
Interpolated sample at: 1710793556.20
Interpolated sample at: 1710793556.60

We should probably schedule a quick technical call. I’ve sent you a DM/PM with a link to schedule a time.

Hey, we are having the same issue. How did you resolve it? @zack_j @Kaitlynyau

Hey there @potato.frogi

For getting power from Spotter, I believe we needed to:
a) fully charge the Spotter
b) run through the diagnostics Victor mentioned above to turn on the bridge power controller (Powering the dev kit from the spotter - #3 by vsowa12)

Let me know if this works for you or not…

Hey. We still haven’t solved the problem of getting power from Spotter. Did you solve it?

Hi there. I think we may have narrowed this down to a damaged board.

We aren’t certain.

I would recommend following the steps above first and if you can’t find a resolution there please be as detailed as possible about what you tried and where you stopped. Generally setting the power controller correctly should take care of power application from Spotter over the Bristlemouth bus.

Please note that the Spotter is charged via the wall wart > USBC that came in the box with the Spotter not the wall wart from the development kit.


We have ensured that our Spotter is charged multiple times so I’m fairly certain that shouldnt be the issue. I also tested the power controller on a specific interval with the dev kit powered from the wall wart and it is able to successfully shut down the bridge communications on the correct intervals. This indicates to me that the power controller is indeed functioning as intended. However, when turned OFF, there is no sign of power leaving the spotter. Would you know if we should expect voltage if we probed the bristlemouth cables from the smart mooring connected to the spotter after we enable continuous power? (we are also starting on a fresh new dev kit and the outlook doesnt seem to have changed, so I heavily suspect that it is more so a Spotter end issue vs the dev kit!)

Yes, you should be getting 24V on the Bristlemouth bus (black and white sockets) whenever the Spotter is on, not in a lower power state, and the power controller is set to continuous.

You can measure right here to confirm there’s not a problem with one of the jumpers or cables.

If you’re measuring 24V, check that all the black and white connections between this and your Dev Kit are connected and looking good. Note that if you’re powering your dev kit from the Spotter you won’t need the wall wart.

If you’re not measuring 24V from that port (make sure that your probes are touching the pins) then please clear the SD card. Put it in the SD card bay and turn on the Spotter for 5 minutes. Take it out and send the contents to me. We’ll take a look and see if there are any strange-nesses (I think we checked this before and it was okay, but let’s check it again).


Oh also please note that you can’t charge the Spotter from the same wall wart as the development kit, you’ll need the USBC charger that came with the Spotter (It’s usually all white).