Setting up a new dev kit

So my team just received a new dev kit board to sub out an old board which ran into some overheating issues. However, when we flashed an app that was working on the previous dev kit board onto the new one we were not able to see the payload bytes we were sending to the dev kit in the serial console. Is there anything we should double check to make sure everything should be operational and communicating as desired? (We checked the baud rates, power controller settings, and physical connections already)

@Kaitlynyau can you post a photo of the front and back of both the new and the old boardstack?

Can you send us the application you were uploading?


I grabbed the pictures for Kaitlyn.

Front/back of old board:

Front/back of new board:

Here’s a link to our user_code and executable we are using. It’s just a very slight modification of the serial payload example app. app code

We’ve checked that our raspberry pi is TX-ing as expected and that the jumpers on the back of the new dev board match the old one. I suspect its some configuration we missed.


One thing I notice is that you’ve deleted this line from the app:


Which enables the PLUART to parse lines and pass them to the user app. Try adding that back into the setup function sometime before the enable call.

Hmmm. Thanks for the tip, a lot of the setup loop was off and I don’t know how that happened. Still no success though.
I flashed the original, unaltered serial payload example app, did all the cfg usr commands, then tested with the first uart script we ever used on our pi (which was the most basic setup we got to work). Still, no buffers are getting through… :sob:

Really sorry to hear you’re having such trouble here. Can you tell us more about your verification of the Pi and of the wires? Maybe post the basic uart script and pics of the system connected together with wires.

Also, if you have any other device besides the dev kit, like an arduino or another pi that you can use to check whether the pi is sending, that would be helpful.

I checked the Pi’s TX pin earlier to make sure we were getting the output we expected - saw a digital output and called it a day. Turns out the high/low were ~700mV/800mV each and I didn’t notice until now. Looks like we just broke another Pi!!
We tested our dev board app with an arduino as the payload and it worked just fine. lol. Thanks as always

1 Like

Haha, hooray! Been there many times. Onward!